The Ticket System (DOWN)
Incident Report for Toad Hall Cottages
Resolved
The Ticket System (UP). this issue has now been resolved.
Posted Sep 12, 2024 - 02:57 BST
Investigating
Website toadhall.freshdesk.com/support/home is down. We are currently investigating the issue
Posted Sep 12, 2024 - 02:55 BST
This incident affected: The Ticket System.