North Wales Holiday Cottages (DOWN)

Incident Report for Toad Hall Cottages

Resolved

North Wales Holiday Cottages (UP). this issue has now been resolved.
Posted Mar 30, 2026 - 18:06 BST

Investigating

www.toadhallcottages.co.uk/healthcheck is down. We are currently investigating the issue
Posted Mar 30, 2026 - 17:52 BST
This incident affected: Websites (North Wales Holiday Cottages).